S/MIME plugin not picking up on application/pkcs7-mime

Marek Sebera's Avatar

Marek Sebera

30 Dec, 2014 08:32 PM


I've got latest S/MIME BETA plugin, and I don't see it picking up on messages with "Content-type: application/pkcs7-mime; name=smime.p7m; smime-type=enveloped-data"

All I see is just attachment "smime.p7m", without S/MIME status in message header (the blue star) and no visible text.
It also doesn't ask me to open any keychain, and Console is free of any messages related to S/MIME plugin.

I've tried to look into source, but it seems like it is not published under github repository (https://github.com/Airmail/AirmailPlugIn-Framework)

Can you please give some status about this issue?

  1. 1 Posted by Stefan on 23 Jan, 2015 12:31 PM

    Stefan's Avatar

    I have very same problem. I am able to encrypt messages, but not way to decrypt!

  2. 2 Posted by Christoph on 15 Jun, 2015 11:04 AM

    Christoph's Avatar

    Same here. All I can see is a single "smime.p7m" attachment. Thunderbird and the Mac OS X default Mail app will correctly identify and display the message, but Airmail doesn't. Any chances that this will be fixed?

  3. 3 Posted by Mali on 04 Aug, 2015 09:03 AM

    Mali's Avatar

    same here. Can this be fixed?

  4. 4 Posted by H1n1 on 05 Dec, 2015 01:22 PM

    H1n1's Avatar

    Bump. Same problem here.

  5. 5 Posted by user on 27 Jun, 2016 08:10 AM

    user's Avatar

    this bug still exists and it is annoying - fix it!

  6. 6 Posted by afx on 05 Jul, 2016 07:20 AM

    afx's Avatar

    I see the smime.p7m in incoming mails (from Outlook).
    But I see clear text in my outgoing S/MIME encrypted mails.
    Both mails to show a lock at the from line in the message viewer.

  7. Support Staff 7 Posted by Airmail on 29 Sep, 2016 12:01 AM

    Airmail's Avatar

    Please have a look to the updated version

  8. 8 Posted by Michael on 29 Sep, 2016 11:06 AM

    Michael's Avatar

    Just installed the newest plugin but still have this problem. Only an attachment "smime.p7m" is visible in the body of incoming encrypted mails.

  9. Support Staff 9 Posted by Airmail on 29 Sep, 2016 01:15 PM

    Airmail's Avatar

    have you updated the plugin correct?

  10. 10 Posted by vlado on 21 Nov, 2016 11:20 PM

    vlado's Avatar

    Still the same in:
    Version 9
    07 OCT 2016, 02:06

  11. 11 Posted by drop on 22 Nov, 2016 05:26 PM

    drop's Avatar
  12. 12 Posted by gwieser on 28 Dec, 2016 02:36 PM

    gwieser's Avatar


    same for me, using Version 9 (which btw reports itself as S/MIME Beta 1.0 (10) in Airmail).

    All I see is the famous smime.p7m attachement, using 10.12.2 (16C67)

  13. 13 Posted by eric on 15 Mar, 2017 01:39 AM

    eric's Avatar

    Does anyone know if there will ever be an update to the plug-in? Or S/MIME support in Airmail? It is the only thing keeping me and all my colleagues from making the switch. Reeeeeeealy love the features and UX in Airmail, but without S/MIME, it's unusable to us.

  14. 14 Posted by totoro on 07 Apr, 2017 10:38 AM

    totoro's Avatar

    Same here, it's a shame I'm forced to use Apple Mail to use encryption! Please fix ASAP!

  15. 15 Posted by josh on 05 Apr, 2018 04:24 PM

    josh's Avatar

    This issue persists in the latest Airmail 3.54 release and the latest S/MIME plugin on the plugins page. I can sign email, encrypt email, but I can't decrypt it. If I send myself an email and use Outlook, I can view the encrypted email just fine.

    Seems like it's not properly using Keychain or something. FWIW, I have the same issue with Apple Mail on High Sierra, so I'm stuck with Outlook.

    When will the plugin be updated or native support added to Airmail?

  16. 16 Posted by martin on 13 May, 2018 06:52 PM

    martin's Avatar

    Same here (AirMail 3.5.6, plug-in just downloaded): signing email seems to work but signed email just shows a big ugly "smime.p7s" attachment icon...

  17. 17 Posted by eric on 14 May, 2018 01:46 AM

    eric's Avatar

    Given this has gone on for three years, and the last update to the plug-in was October 2016, I think we can assume the developer has ended the project, that no one else is inclined to develop a plug-in, and that the Airmail developers have no intention of supporting encryption natively.

    It's a shame - the UX is so wonderful in Airmail, that I'd enjoy using it in the enterprise and for personal communications. But as it is - it's more for the Hipstergram Facespace crowd. Which is understandable, if disappointing. So it's long-since been deleted from my devices. I have to, regrettable, suggest sticking with Apple's Mail.app - it's faster, more stable, more secure, and supports S/MIME with ease.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

29 Jul, 2021 08:52 AM
28 Jul, 2021 08:45 AM
28 Jul, 2021 06:08 AM
29 Jun, 2021 10:59 AM
29 Jun, 2021 10:32 AM