Can we simply make search functionality working?

Leon Guan's Avatar

Leon Guan

23 Nov, 2017 09:52 AM

This is really a headache, the search functionality is totoally wasted in Airmail. It never worked out, no matter input what for search, it always return to messages totally not related. Tried to removed the accounts and added again, tried to clear the caches, this issue has been there for years. I really like everything else brought by Airmail, but everytime I need to search for emails, I have to open webmail. I cannot believe the search feature is so hard to be developed. I saw threads here and feedbacks else where complained about search features in Airmail is kind of crippled, don't know why this issue can be kept as it is for such a long time. Please, can we at least have sorts of workaround?

  1. Support Staff 1 Posted by Airmail on 23 Nov, 2017 04:32 PM

    Airmail's Avatar

    we need a more specific and detailed case
    can you make some screenshots and details?

  2. 2 Posted by Leon Guan on 23 Nov, 2017 05:38 PM

    Leon Guan's Avatar

    Sure, please see the attached first three images.

    1. Before the search
    2. I input "airmail" for search, you can 614 mails returned as the count
    3. I selected one of the returned result, you can see, it's nothing to do with keyword "airmail", and the result has been turned to 616.

    No matter what I input for search, always return hundreds of emails, totally none related.

    And please check the attached screenshots, search "airmail" with Spark, within exactly same mailboxes, and please check the returned result, only 48 count and every one of them is related.

    Please, I really like to use Airmail and not willing to switch from it. This issue has been there very long time, it's unbelievable that it's a hard issue to be fixed.

    Thanks for your time.

  3. Support Staff 3 Posted by Airmail on 23 Nov, 2017 09:35 PM

    Airmail's Avatar

    can be the result is in the message content?
    is a gmail account?

  4. 4 Posted by Leon Guan on 24 Nov, 2017 06:29 AM

    Leon Guan's Avatar

    Please check the screenshot for that mail content, which title has [HuntorNAS] as the beginning. And you can see the content of the message, no "airmail" in the message at all. I especially picked a mail with simple content so that you can easily see the problem. Actually, there are too much results returned for the keyword, most of them are totoally non-related to searched keywords.

    And no, it's not an Gmail account. But I do have a gmail account, and there are non-releated messages returned too.

  5. Support Staff 5 Posted by Airmail on 25 Nov, 2017 11:16 AM

    Airmail's Avatar

    can you go to settings>account -> rebuild message cache
    for the gmail account
    let Airmail download the messages again and try to search again after a bit?

  6. 6 Posted by Leon Guan on 25 Nov, 2017 04:04 PM

    Leon Guan's Avatar

    I just did more tests, have some more findings.

    • I have three mail accounts, one gmail account, one icloud account, and one IMAP account provided by Tencent QQ enterprise mail system.
    • I found, if I selected All Accounts and search, the results list will be correct for one or two seconds and then lots of mails will returned and messed up the list
    • And If I select only Gmail, or icloud mail account, the results are ok
    • And if I switched back to All Accounts, and then search again, sometime, the result will be ok.
    • If I select the IMAP account by Tencent, and saerch, the result are totoally wrong.
    • So I believe the generic IMAP account was having issue on search. I disable the account from Setting and try again in All Accounts, confirmed the search is ok.
    • I have just clean the message caches for that mail box, but no luck, the issue is still there.

    Anything else I can do to figure it out?

  7. Support Staff 7 Posted by Airmail on 29 Nov, 2017 11:44 AM

    Airmail's Avatar

    so this is the problem
    when AM searches:
    1) it get the local messages and that is working
    2) get the message on imap server

    for some reason some of your imap server are returning wrong result for our search
    can you provide a test account for that kind of server?

  8. 8 Posted by Leon Guan on 08 Dec, 2017 04:51 PM

    Leon Guan's Avatar

    Can you give me an emaill address so that I can create a test account for your to test with the IMAP server which has the issue?

  9. 9 Posted by zenek on 08 Dec, 2017 10:36 PM

    zenek's Avatar

    I have similar issue. I have found an old mail (24-09-2012) in Mail. No problem with searching. When I tried to find it in AirMail - it wasn't found. When I select it in AirMail and it was read then the mail was find while searching. It's IMAP account with "Download all messages" enabled. But I can see that when I scroll list of mails to 2012 then first 2 lines of each mail are not read -only after ~ 1 sec they appear.
    It seems that there is a big problem with searching in old mails :/
    No such problems with native Mail

  10. Support Staff 10 Posted by Airmail on 22 Dec, 2017 06:49 PM

    Airmail's Avatar

    we are working on the search
    any help or report is welcome

  11. 11 Posted by Andy on 12 Oct, 2018 10:39 AM

    Andy's Avatar

    I confirm such situation can be replicated:
    the results list will be correct for less than two seconds, then the whole list of mail comes in.
    It appears to be a protocol mismatch between AM and some IMAP servers.
    How can I help to resolve this issue? this is very critical to me.

  12. 12 Posted by Richard on 07 Nov, 2018 03:34 PM

    Richard's Avatar

    Believe it or not, I'm running v1.4 and was going to upgrade to v3 because I assumed by now that the search functionality would have improved (hence never upgrading previously). Looks like I need to wait a while longer. If there is a demo version available for me to check for myself that would be great.

  13. 13 Posted by Wouter on 09 Nov, 2018 04:42 AM

    Wouter's Avatar

    Running version 3.5.8
    I'm finding the search function infuriating.
    This is what happens: I see an email with content that I know would be present in other email ( like a payment reference) I copy the text that want to search for from that email body and yet when I search for it I get zero results in the search even though I just copied and pasted text from an email inside AIRMAIL3 .
    I have to agree with the originator from this post. "This issue has been there very long time, it's unbelievable that it's a hard issue to be fixed"

  14. 14 Posted by Stephen on 10 Mar, 2019 06:19 AM

    Stephen's Avatar

    +1 for resolving searching, it is by far the weakest part of Airmail, and the most frustrating. Results are wrong and inconsistent as mentioned above, and have been this way for as long as I can remember.

  15. 15 Posted by Rob Medich on 02 Apr, 2019 03:38 PM

    Rob Medich's Avatar

    In general, I think the search function is poor and non-intuitive. There seems to be no obvious way (or maybe no way at all) to search with more than one variable. For instance: I can choose to search for the word "beach" in headers. But I can't then also specify which folder I want to search in.

    If this functionality exists, then please tell me how to make it work. Also, I shouldn't have to think this hard to figure it out. It should be intuitive. Keep in mind WE PAID FOR THIS APP.

  16. 16 Posted by Aaron on 24 May, 2019 10:10 AM

    Aaron's Avatar

    is this issues been solved? I have same problems now....

  17. 17 Posted by Rob Medich on 24 May, 2019 03:03 PM

    Rob Medich's Avatar

    Given that absolutely nothing has changed with the search function, I don’t
    know why you would expect this issue to be solved. Have you changed


    From: Aaron <[email blocked]>
    <[email blocked]>
    Reply: [email blocked] <[email blocked]>
    <[email blocked]>
    Date: May 24, 2019 at 6:10:43 AM
    To: [email blocked] <[email blocked]> <[email blocked]>
    Subject: Re: Can we simply make search functionality working? [Airmail Mac
    Beta #8254]

  18. 18 Posted by Michael Glass on 29 Aug, 2019 06:11 PM

    Michael Glass's Avatar

    iPad OS can’t seem to get newer_than:1d or older_than:1d search queries to work.
    Do Google search operations only work on Google accounts?
    My goal is to make a smart folder with criteria:
    newer_than:1d label:inbox

    Thank you.

  19. 19 Posted by LS on 17 Jan, 2020 09:08 PM

    LS's Avatar

    Hi there, I've had the same problem from the day I started using Airmail 3 - had incredible support from Steven at Love Support - but in truth the search is just dire - which is sad because everything else is just GREAT - but no matter what you try - how many times you REBUILD - the search function is practically non-existent just don't understand how it's possible that it can be SO BAD - even thinking about going back to MAIL OS just because it really effects work-flow - the only slightly better solution is using SPOTLIGHT - Sincerely LS

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

29 Jul, 2021 08:52 AM
28 Jul, 2021 08:45 AM
28 Jul, 2021 06:08 AM
29 Jun, 2021 10:59 AM
29 Jun, 2021 10:32 AM