Paste Text Only Not Functioning

Mark Witkowski's Avatar

Mark Witkowski

25 Oct, 2017 06:47 PM

Hi,
When pasting as 'Paste Text Only' option, there is custom formatting applied to the text. Looking at the HTML on pasted text using this method, I see:

This div is breaking the Composer rules set in the account preferences and overriding the HTML formatting set in the message for that line.

If you need more info please let me know.

Mark

  1. Support Staff 1 Posted by Airmail on 04 Nov, 2017 01:32 PM

    Airmail's Avatar

    use the plain text composer option

  2. Airmail closed this discussion on 04 Nov, 2017 01:32 PM.

  3. Mark Witkowski re-opened this discussion on 06 Nov, 2017 11:33 AM

  4. 2 Posted by Mark Witkowski on 06 Nov, 2017 11:33 AM

    Mark Witkowski's Avatar

    Hi - thanks for your response. However, you did not address the reported bug. When using the Airmail options from the Edit menu for 'Paste Text Only' and now I see it also with 'Paste and Match Style' -- the Airmail program does not properly insert the text. The result is an HTML email with multiple text styles in the HTML and an email message that is inconsistently formatted. Of further note, the message viewed in the Airmail UI looks fine to the sender and is of deeper concern. This is a bug.

    To replicate:
    1. Start an email in Airmail
    2. Take text copied from another location and paste into email using the options to 'Paste Text Only' or 'Past and Match Style'
    3. Look at the underlying HTML in the Airmail message and note the new div with an id of bloop_customfont and an inline style for the margin of 0 -- this is the problem.

    While I am using a custom font setup in my preferences, all of my other text lines that I type directly into Airmail have an inline style on the div:
    style="font-family:Calibri,Arial;font-size:13px; color: rgba(0,0,0,1.0); margin: 0px; line-height: auto;"

    I encourage you to look deeper into this issue as having consistent formatting in messages viewed by recipients is an expected behavior of an email client - especially if it looks good in the Airmail UI propr to sending.

    Mark

  5. 3 Posted by Mark Witkowski on 16 Nov, 2017 11:35 AM

    Mark Witkowski's Avatar

    I have researched this issue further and have found that the bug is actually present when doing a copy/paste of text within an email. Steps to repeat:
    1. Copy a line of text from a message in Airmail
    2. Return key 2 times
    3. Paste onto a new line

    The line of pasted text does not carry the custom text formatting in preferences and the result is problematic. In the Airmail UI, the text looks fine -- however in the delivered message the styling of the 2 lines of text is different due to the pasted line not getting the proper style tags.

    Screenshot attached.

  6. Support Staff 4 Posted by Airmail on 23 Nov, 2017 04:38 PM

    Airmail's Avatar

    I guess there is a custom basic formatting for all the mail

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

29 Jun, 2021 10:59 AM
29 Jun, 2021 10:32 AM
01 Jun, 2021 06:34 AM
22 Apr, 2021 04:33 AM
21 Apr, 2021 06:18 AM