Mail not sending

miguel.rosario's Avatar


09 May, 2017 05:43 PM

When I am sending mail it will go into drafts folder and will not send. I have checked the connections to the email server and it is connected. The email in drafts folder says waiting. I tried restarting the program and it turns it into failed and when I try to resend it just says waiting. I tried a different email that I am sending it from and does the same thing. Any ideas on how to get this to work?

  1. Support Staff 1 Posted by Airmail on 10 May, 2017 03:40 PM

    Airmail's Avatar

    did you update to v429?

  2. 2 Posted by Cal Hultgren on 10 May, 2017 08:27 PM

    Cal Hultgren's Avatar

    I have the same problem [v 3.2.5 (424)]. How do I upgrade to v429 when I bought this via the app store? The App Store says all apps are current.

  3. Support Staff 3 Posted by Airmail on 10 May, 2017 08:41 PM

    Airmail's Avatar
    this is the beta link
    to install gmail account you need to delete the store version ( you can download again it later)

  4. 4 Posted by davidhobbs83 on 18 May, 2017 07:26 AM

    davidhobbs83's Avatar

    I have the same problem on version 432.

  5. Support Staff 5 Posted by Airmail on 18 May, 2017 12:17 PM

    Airmail's Avatar

    what account type?
    gmail / exchange/ imap?

  6. 6 Posted by Steve Crow on 19 May, 2017 05:52 PM

    Steve Crow's Avatar

    On version 432 and I have the same issue with an Exchange account - from within Airmail I cannot send messages from this account or to this account. From within Airmail I've checked the account setup and it passes the connection verification test.

    If I use the web interface to my Exchange account - everything appears normal.

  7. Support Staff 7 Posted by Airmail on 19 May, 2017 05:55 PM

    Airmail's Avatar

    Are you using the the one with the link?

  8. 8 Posted by Steve Crow on 19 May, 2017 05:57 PM

    Steve Crow's Avatar

    I am on a Mac and my software is automatically kept up to date.


    Steve Crow

  9. 9 Posted by Andy Kennedy on 19 May, 2017 08:41 PM

    Andy Kennedy's Avatar

    As per conversation with Mark on support chat, I too am seeing this issue.

    My environment is as follows:

    macOS Sierra 10.12.5
    Airmail App 3.2.7 (432)
    MacBook 12"

    Corporate Gmail account.


    Sending email intermittently fails (copy is stored in Drafts folder).

    Restarting the app generally clears the issue, however it then subsequently returns. Note, the machine is not put into sleep mode between issues occurring etc, rather it is being used constantly for the duration.

    Some operations (both copy and move) remain stuck in a pending state (manually clearing these does not appear to resolve the issue either).

    Best regards

  10. Support Staff 10 Posted by Airmail on 20 May, 2017 02:51 PM

    Airmail's Avatar

    can you install the latest beta

    can you send logs after the beta install?

  11. 11 Posted by jhnjnk on 24 May, 2017 07:31 AM

    jhnjnk's Avatar

    I am having the same issue. After this issue and the BCC issue, I am really on the fence with Airmail. I love the app - some many great capabilities. But it is failing at the very basics of email.

    I found out that sending wasn't working when I had to get a file to a client of mine on a tight deadline and he kept calling me saying he didn't have it. I now wonder how many other emails of mine haven't been delivered.

  12. 12 Posted by Ciaran Doran on 24 May, 2017 10:21 AM

    Ciaran Doran's Avatar

    I'm having a similar problem.
    When I write an email and for some reason the Wifi drops out the email tries to send, fails to send and so Airmail dumps it into the Draft folders.
    The problem is twofold,
    - one it doesn't tell me it did this and simply dumps the mail into Drafts. - secondly, I'm so used to other apps that keep the mail in the outbox and tries to send when next online. That means I'm not used to constantly checking whether something has been sent or not. This is getting me into trouble at work because something isn't being sent when I thought it had already been sent.

    Airmail, can you please fix this, perhaps by creating an outbox where the message sits and gets automatically sent from when next online.
    Like the previous user I love Airmail but will likely have to move if this and a few other things don't get sorted soon. But thats a bit of a moot point since you already have my money - but I would pay for upgrades each year if necessary.

  13. 13 Posted by Jesus Felix on 24 May, 2017 12:46 PM

    Jesus Felix's Avatar

    me too. sigh

    wil not send with pdf attachments the first time
    re created the email from scratch, and it worked the second time

  14. Support Staff 14 Posted by Airmail on 24 May, 2017 12:54 PM

    Airmail's Avatar

    please send logs, form the app ... menu and describe the issue

  15. 15 Posted by Ciaran Doran on 24 May, 2017 05:26 PM

    Ciaran Doran's Avatar

    Airmail Support - don't understand.
    No 'error log' is created that I know of.
    This is a feature issue.
    It seems that the application has been designed to only try to send an email once and if that fails then dump it into the Drafts folder. That's not the way any other email application that I've ever used works. So it's peculiar that Airmail works like this.
    To fix it would involve the app trying to send the mail next time network activity is detected - don't know how you make that happen but all other email apps that I've used make it happen.
    Thanks for reading these and responding, much appreciated :)

  16. 16 Posted by Elaine on 24 May, 2017 09:06 PM

    Elaine's Avatar

    Ya, mine was doing the same thing. Embarrassing when you KNOW you've sent something. Also my rules stopped working and I'm not receiving email to my IMAP account. I have to go into my Mac Mail to get those. I was told to download the beta and that I would have to set my preferences again. This app has one heck of a lot of preferences. My rules still don't work. Now I have to redo my rules! That's just messed up! I just discovered that my incoming mail is going into my trash folder and I lost some of it before I could open it. I just downloaded the latest beta Version 3.2.9 (437). I think it's just a dummy fix cos it didn't do anything.

  17. Support Staff 17 Posted by Airmail on 25 May, 2017 12:07 AM

    Airmail's Avatar

    to send logs >

    about v437 it has more retry-send and a better connection check before sending

    about installing beta there is a the possibility to export import rule from rule panel

    about rule > which kind of rule is not working ?

  18. 18 Posted by Elaine on 25 May, 2017 01:09 AM

    Elaine's Avatar

    I don't understand what you are saying here.

    My app doesn't show the same thing as following the link under "More" "Send Logs." I don't have that option.

    I have to check my trash to find my mail.

  19. Support Staff 19 Posted by Airmail on 25 May, 2017 01:20 AM

    Airmail's Avatar

    enable debug tools
    restart the app and run a bit until the problem is replicated

  20. 20 Posted by Elaine on 25 May, 2017 01:38 AM

    Elaine's Avatar

    Until the problem is replicated? It's not like i can receive email on demand.

  21. Support Staff 21 Posted by Airmail on 25 May, 2017 01:44 AM

    Airmail's Avatar

    so if you have sync issues
    run the beta in that configuration and send logs with a short description of the case

  22. 22 Posted by Elaine on 25 May, 2017 01:35 PM

    Elaine's Avatar

    I don't have anywhere that shows run logs as your photo depicts. I just discovered that I can't take my mail out of trash. There is no longer a function to right click. I just put in a complaint to Apple/iTunes. I just noticed there's yet another update. My eyes are starting to roll.

  23. 23 Posted by aaron on 30 May, 2017 08:30 PM

    aaron's Avatar

    having this problem again.. Had it in the past and abandoned Airmail then recently got the new series of betas and the problem was not apparent so moved to paid version and added corp accts.. now, it is doing it again..

  24. 24 Posted by Mark Campbell on 21 Jun, 2017 09:09 PM

    Mark Campbell's Avatar

    I am having the same issue and has been ongoing now for the past 2 months. It has just got much worse. I am running 3.3.2 (442). It only sends if you close down Airmail and reopen. Once you reopen Airmail it sends immediately

  25. 25 Posted by Maria on 25 Jun, 2017 09:21 PM

    Maria's Avatar

    Having this problem our traveling computer, but not our other that stays at home. It is not the wifi connection. It is only on my MacBook Air:(

  26. 26 Posted by eugenio on 28 Jun, 2017 04:25 PM

    eugenio's Avatar

    I noticed this problem some months ago, the bad thing for me is that I don't find the unsend mail: it is not in the draft!

    I was running 3.2.1, tried to update to beta but when I saw that it asked to start from scratch I turned back to 3.2.1 and than upgraded via App Store to 3.3.2. Maybe at least I'll have the unsent mail saved to drafts!!!!!!

    Anyway, I use Gmail and two corporate emails, imap, on a macbook pro i7, 16Gb, SSD.. running Sierra 10.12.5. I have thousand mails and i find the search really far SLOOOOWER than Mail.

    Is it possible to switch to beta without a complete reinstall?


  27. 27 Posted by Mark Chapman on 29 Jun, 2017 12:48 AM

    Mark Chapman's Avatar

    Yes, I have been having this same issue of mail not sending and getting stuck in the drafts folder. A forced quit of the program and a restart usually fixes the issue. for awhile until it does it again. The issue happens on the App Store and the Beta version in our exchange accounts. It happens on all three of our computers with AirMail installed. I have raised this issue with the support team via the on-line chat several times, but still it has not been solved. What was looking like a good program when first purchased is now looking like a waste of money for the amount of problems it is causing. Is there any plan to fix this issue soon?

  28. 28 Posted by Mark Campbell on 29 Jun, 2017 12:53 AM

    Mark Campbell's Avatar

    Agreed that this is very frustrating. I have had no response on this issue for weeks despite following instructions to:
    • Send logs (no response) • Updating to latest version - no change and again no response The problem seems to be directly related to Exchange accounts and is intermittent but getting more frequent.

  29. 29 Posted by Mark Chapman on 29 Jun, 2017 01:02 AM

    Mark Chapman's Avatar

    Yes, it is the intermittent aspect that makes it hard to nail down. I have tried changing the "delay sending" settings to see if there is a pattern but nothing is consistent yet. I have just changed the firewall settings in the Apple preferences and added AirMail in the list of allowed programs to see if that makes a difference. I will try this for awhile and see what happens.

  30. 30 Posted by David on 29 Jun, 2017 09:58 AM

    David's Avatar

    Same here. Today is even worse, I've restarted my machine 2 times after I tried the quit and open technique 5 times, 15 emails as "local sent" and lots of new emails that aren't being pulled down. Any help here is really appreciated!

    Thank you :)

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac