Unable to close properly Airmail without killing it

frenchbeast's Avatar


08 May, 2017 08:35 PM

Unable to close properly Airmail without killing it
And i request Airmail application to quit, the CPU starts to climb to 100%
The application is unresponsive.
So i have to kill it every time

  1. Support Staff 1 Posted by Airmail on 09 May, 2017 06:36 AM

    Airmail's Avatar

    preference>account>more>rebuild message cache

  2. 2 Posted by frenchbeast on 13 May, 2017 12:59 AM

    frenchbeast's Avatar

    Tried that few times.
    It will fix it for a while.
    The problem will come back.

  3. 3 Posted by Kencathedrus on 13 Sep, 2018 05:46 PM

    Kencathedrus's Avatar

    I have exactly the same problem. Deleted, reinstalled the app, reset message caches, CPU rockets to over 100%, have to force quit. This app was really good, but the current issues are forcing me to look for other mail apps.

  4. 4 Posted by Kencathedrus on 27 Sep, 2018 12:49 AM

    Kencathedrus's Avatar

    I've solved the problem for myself. It turns out it was my Exchange account. My work uses Outlook but for some reason I could only configure it on Airmail as an Exchange account. I noticed I was having similar issues with this account on Spark mail, and that's what made me discover there was a compatibility problem. What solved it for me was to delete the Exchange account and reconfigure it as an IMAP account. Since then Airmail has worked perfectly for me. CPU has remained stable and the app remain workable - no more freezes.

    A bunch of error email messages also appeared in my inbox soon after, which gives me the impression that there was some sort of bottleneck between the two servers, and that some endless looping process was causing Airmail to use too much CPU.

    Hope this information helps anyone else going through the same thing. It was really frustrating because I had come to depend on Airmail but this problem was making it unworkable.

  5. 5 Posted by E.J. Chichilnis... on 20 Aug, 2019 03:28 PM

    E.J. Chichilnisky's Avatar

    I had the same problem with an Exchange account. I was able to solve the problem by launching Airmail, inactivating (not deleting) the Exchange account, quitting, relaunching, and then re-activating the Exchange account. I hope this works for other people too because it was pretty frustrating.

  6. 6 Posted by E.J. Chichilnis... on 20 Aug, 2019 03:30 PM

    E.J. Chichilnisky's Avatar

    I "spoke" too soon. The above worked as I wrote, but only for a few minutes, during which I wrote that post. Then the problem returned. :(

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

29 Jul, 2021 08:52 AM
28 Jul, 2021 08:45 AM
28 Jul, 2021 06:08 AM
29 Jun, 2021 10:59 AM
29 Jun, 2021 10:32 AM