Markdown editor bug - multiple dashes are auto-converted to a hyphen

plta.shop+airmail's Avatar

plta.shop+airmail

08 Jun, 2017 02:36 PM

In the Markdown editor, If I want to create a table like:

Tables Are Cool
col 3 is right-aligned $1600
col 2 is centered $12
zebra stripes are neat $1

I am unable to do so, due to a bug. The reason being is that when entering multiple "-" characters in a row, they are automatically converted to "—", and then do not render properly. The only work around is to copy/paste the dashes from another editor.

A sample email showing the results is attached.

  1. Support Staff 1 Posted by Airmail on 20 Jul, 2017 10:57 PM

    Airmail's Avatar

    thanks

  2. 2 Posted by michael on 22 May, 2018 10:24 PM

    michael's Avatar

    For anyone reading this, I discovered a work-around. You can right click in the Markdown editor and disable "Smart Dashes" under "Substitutions".

    It would be awesome to have this disabled by default in the Markdown editor in Airmail.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • markdown_tables.eml 7.34 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

13 Aug, 2018 06:09 PM
11 Aug, 2018 06:26 PM
09 Aug, 2018 06:21 PM
06 Aug, 2018 02:31 PM
06 Aug, 2018 10:50 AM

 

03 Aug, 2018 09:56 AM
03 Aug, 2018 09:35 AM
02 Aug, 2018 02:05 PM
30 Jul, 2018 07:57 PM
29 Jul, 2018 10:15 AM
26 Jul, 2018 09:02 PM