Airmail exchange account keeps loosing connection/authentication

Roderik Planken's Avatar

Roderik Planken

17 Oct, 2016 06:08 PM

In build 391 and those builds form the past 3 months I am experiencing that although the account can be set up successfully, and initial authentication works, after an hour or two suddenly the exchange server connection refuses to stay up and Airmail will just not connect again, highlighting the account icon with the red circle. When going to account setup and clicking "test", it comes back each time i try with "Exchange server settings invalid" and "Authentication failed". I know 100% sure that the account username and password I use are correct. Only way to restart a successful login is to completely reboot my MAC Macbook Pro Retina Summer 1012 running El Capitan.
And after 1-2 hrs same problem happens again.
Any ideas? I already rebuild / reinstalled Airmail several times...no change.

Showing page 4 out of 4. View the first page

  1. 91 Posted by codethought on 18 May, 2017 02:57 AM

    codethought's Avatar

    "can you try this version? http://d.pr/f/xlj3z"

    Just did.. this one works fine so far..

  2. 92 Posted by David Thorpe on 18 May, 2017 06:49 AM

    David Thorpe's Avatar

    "can you try this version? http://d.pr/f/xlj3z"

    This seems to be working for me so far (about 1.5 hours). Just a couple of queries:

    1. This has installed as a separate app ("Airmail Beta"). Presumably these changes will at some point make their way back to the MAS version?

    2. My Gmail account won't authenticate. I think it's because when Gmail authorises the app (via the Google web page that fires when you add the Google Account in Airmail's preferences) it is authenticating "Airmail 3" not "Airmail Beta". I'm sure that's the case because the original Airmail 3 opens in my dock every time I try and authenticate.

    3. This seems to have taken me back to version 3.2.6 (432) whereas the MAS release is 3.2.7 (432). Is that right?

    Thanks.

    David

  3. Support Staff 93 Posted by Airmail on 18 May, 2017 12:18 PM

    Airmail's Avatar

    Hi David
    1 we will send a new MAS release with the fix soon
    2 yes is better to have one of the 2 apps not both on your system
    3 don't worry for the version I just need to update that

    thanks for testing
    please let us know if the problem is fixed for you

  4. 94 Posted by Joao Cruz on 18 May, 2017 05:58 PM

    Joao Cruz's Avatar

    Hi,

    On the last few days I have a connection issue to exchange online.

    The account becomes red and no connection is established. cannot send or receive email.

    closing and opening Airmail fixes this for 2 to 10 minutes. All is well and bam ... it happens again.

    Reseted the cache completely.

    Installed the above mentioned version. I'm now on build 377 and the same sympthom

    Please help !!

    It's impossible to work like this.

    Up to a few days ago I was a totally happy AirMail user.

  5. 95 Posted by codethought on 19 May, 2017 01:01 AM

    codethought's Avatar

    "can you try this version? http://d.pr/f/xlj3z"

    BTW that build had the same problem.. eventually it disconnected and would not reconnect..

  6. Support Staff 96 Posted by Airmail on 19 May, 2017 09:35 AM

    Airmail's Avatar

    codethought > are you on office 365?
    Joao Cruz > you have an old version update to our latest beta

    or just use this link http://d.pr/f/fqLkj this is a newer version

  7. 97 Posted by rachel on 19 May, 2017 12:12 PM

    rachel's Avatar

    I have the same problem in V.27. Have to forcequit & restart it several times to get exchange mail back online.

    OS X
    v.10.11.16

  8. 98 Posted by codethought on 19 May, 2017 12:28 PM

    codethought's Avatar

    "Joao Cruz > you have an old version update to our latest beta

    or just use this link http://d.pr/f/fqLkj this is a newer version"

    I did that.. same problem.

    And yes I'm on Office365

  9. Support Staff 99 Posted by Airmail on 19 May, 2017 01:01 PM

    Airmail's Avatar

    did you install the version from the link?
    can you provide some logs?
    seems strange to me I have other users reporting the problem is fixed with the linked version

  10. 100 Posted by João Cruz on 19 May, 2017 01:59 PM

    João Cruz's Avatar

    Same problem with whatever version i install

  11. Support Staff 101 Posted by Airmail on 19 May, 2017 02:11 PM

    Airmail's Avatar

    Joao Cruz is an exchange office365 account?

  12. 102 Posted by João Cruz on 19 May, 2017 02:45 PM

    João Cruz's Avatar

    I’m using

    Outlook Officer 365

    https://outlook.office365.com/EWS/Exchange.asmx

    Ligado 19 de maio de 2017 no 13:28:39, codethought ([email blocked]<mailto:[email blocked]>) escreveu:

  13. Support Staff 103 Posted by Airmail on 19 May, 2017 02:46 PM

    Airmail's Avatar

    can you send me some logs?
    app bar > 3 dots button > more > send logs

  14. 104 Posted by João Cruz on 19 May, 2017 03:02 PM

    João Cruz's Avatar

    Cannot do that.

    It tries to generate a 149MB attachement file.

    Any alternative ?

    Ligado 19 de maio de 2017 no 15:47:05, Airmail ([email blocked]<mailto:[email blocked]>) escreveu:

  15. 105 Posted by Adrian Atherall on 19 May, 2017 08:34 PM

    Adrian Atherall's Avatar

    I am also experiencing this issue with an office 365 account - Version 3.2.7 (432)

    Doesn't seem like any of the posted beta's have the fix.

  16. Support Staff 106 Posted by Airmail on 20 May, 2017 03:23 PM

    Airmail's Avatar
  17. 107 Posted by João Cruz on 22 May, 2017 09:19 AM

    João Cruz's Avatar

    Perfect !

    Fixed it.

    Thank you.

    Ligado 20 de maio de 2017 no 16:24:06, Airmail ([email blocked]<mailto:[email blocked]>) escreveu:

  18. Support Staff 108 Posted by Airmail on 22 May, 2017 03:14 PM

    Airmail's Avatar

    ok

  19. Airmail closed this discussion on 22 May, 2017 03:14 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

29 Jul, 2021 08:52 AM
28 Jul, 2021 08:45 AM
28 Jul, 2021 06:08 AM
29 Jun, 2021 10:59 AM
29 Jun, 2021 10:32 AM